Имя: Пароль:
1C
 
Вылетает 1с конфигуратор при создании внешнего отчета ☑
0 Tolstiy Beremenniy
 
24.10.18
✎
06:44
Создаю внешний отчет, что бы сделать выборку на СКД.
Пишу наименование, как я понял не важно на каком языке.
Нажимаю Tab что бы перейти к синониму и продолжить разработку,
но выходит ошибка, -

"Ошибка SDBL
В схеме базы данных нет таблицы с именем ExtensionsInfo."

И можно завершить работу или перезапустить.

Из за чего такое бывает? И есть ли методы устранения?
1 Мимохожий Однако
 
24.10.18
✎
06:48
Вместо TAB нажми СОХРАНИТЬ. А потом делай то, что хочешь.
2 Tolstiy Beremenniy
 
24.10.18
✎
08:11
(1) Раньше я всегда так делал в файловых базах.
Эта SQL серверная. Создаю внешний отчет, ввел название,
нажал сохранить. вылетело так же как в (0).
Получается не тот случай, что можно это обойти.
говорят если открыть существующую обработку, и поправить,
то сохранить дает.
3 Tolstiy Beremenniy
 
24.10.18
✎
08:16
Можно открыть существующий и переделать на заготовку,
на разрабатываемый. С базой видимо проблемы.
4 Остап Сулейманович
 
24.10.18
✎
08:25
(3) "С базой видимо проблемы."
Абсолютно нет. Проблемы с правами. Попроси себе админских прав .
А вообще обходится так : Файл-Открыть. При этом не обязательно что-нибудь открывать. Главное, что б окошко проводника появилось. Закрыть. Потом записывать то, что нужно.
5 Vladal
 
24.10.18
✎
08:55
(0) Цитирую:

Изменение имени внешней обработки
Код ошибки: 10176461
Код(ы) обращения: SW1143706 TP#15641
Статус: Исправлена в будущей версии Зарегистрирована: 28.03.2017
Исправлена: "Технологическая платформа", версия 8.3.10

Описание:

В конфигураторе, в режиме совместимости "Версия 8.3.5" или ниже, при изменении имени внешней обработки происходит ошибка

Ошибка SDBL. В схеме базе данных нет таблицы с именем ExtensionsInfo

и аварийное завершение работы программы.
6 Tolstiy Beremenniy
 
24.10.18
✎
09:40
(5) Тут версия платформы.

1С:Предприятие 8.3 (8.3.10.2168).

И при изменении все работает.

А вот вылетает при создании.

(4) Стоят полные права. И администрирование внешних форм
и обработок, то есть.
7 Tolstiy Beremenniy
 
24.10.18
✎
09:41
(5) В конфигураторе стоит режим совместимости 8.2.13
8 Cyberhawk
 
24.10.18
✎
09:54
Проверь скорее на пустой инфобазе без режима совместимости и отпишись
9 Tolstiy Beremenniy
 
24.10.18
✎
10:00
(8) Серверную я не смогу создать.
10 Cyberhawk
 
24.10.18
✎
10:00
Файловую создай
11 Cyberhawk
 
24.10.18
✎
10:01
С режимом совместимости как в проблемной базе тоже проверь заодно
12 Tolstiy Beremenniy
 
24.10.18
✎
10:04
Тут такая проблема.
Локальные базы вообще не запустить.
Не обнаружен ключ лицензии!!!
то есть может работать только что подключено
из SQL Server. Так ничто не запускается!!!
13 Tolstiy Beremenniy
 
24.10.18
✎
10:07
То есть, из локального ничего ни создать, ни открыть.
Не посмотреть получается.
14 Cyberhawk
 
24.10.18
✎
10:11
Ясно. Плохи твои дела.
15 lxs
 
24.10.18
✎
10:16
Опция Расширения доступна?
16 Tolstiy Beremenniy
 
24.10.18
✎
10:38
(15) При добавлении объекта в расширение, пишет, -
Структура данных не поддерживает хранение расширений.
Необходимо отключить режим совместимости.
17 lxs
 
24.10.18
✎
11:57
(16) Совместимость почему такая убогая? Сами понижали?
18 Tolstiy Beremenniy
 
24.10.18
✎
12:22
(17) Не владею информацией. (
AdBlock убивает бесплатный контент. 1Сергей